What’s Vulnerable › Vulnerabilities
CVE-2017-15134
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-01 · updated 2026-06-17
- Weakness: CWE-120
Description
A stack buffer overflow flaw was found in the way 389-ds-base 1.3.6.x before 1.3.6.13, 1.3.7.x before 1.3.7.9, 1.4.x before 1.4.0.5 handled certain LDAP search filters. A remote, unauthenticated attacker could potentially use this flaw to make ns-slapd crash via a specially crafted LDAP request, thus resulting in denial of service.
Affected products
- Red Hat, Inc. 389-ds-base: from 1.3.6.1 before 1.3.6.13; from 1.3.7.1 before 1.3.7.9; from 1.4.0.0 before 1.4.0.5 — fixed in 1.3.6.13, 1.3.7.9, 1.4.0.5
- Red Hat Enterprise Linux: 7.4
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0, 7.4
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Red Hat, Inc. 389-ds-base 1.3.6.13, 1.3.7.9, 1.4.0.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00033.html
- http://www.securityfocus.com/bid/102790
- https://access.redhat.com/errata/RHSA-2018:0163
- https://bugzilla.redhat.com/show_bug.cgi?id=1531573
- https://lists.debian.org/debian-lts-announce/2018/07/msg00018.html
- https://pagure.io/389-ds-base/c/6aa2acdc3cad9
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00033.html
- http://www.securityfocus.com/bid/102790
- https://access.redhat.com/errata/RHSA-2018:0163
- https://bugzilla.redhat.com/show_bug.cgi?id=1531573
- https://lists.debian.org/debian-lts-announce/2018/07/msg00018.html
- https://pagure.io/389-ds-base/c/6aa2acdc3cad9
Get alerted when CVE-2017-15134 or the next vulnerability affects your stack