What’s Vulnerable › Vulnerabilities
CVE-2017-15412
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-28 · updated 2026-06-17
- Weakness: CWE-416
Description
Use after free in libxml2 before 2.9.5, as used in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Google Chrome: before 63.0.3239.84 — fixed in 63.0.3239.84
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Workstation: 6.0
- xmlsoft libxml2: before 2.9.5 — fixed in 2.9.5
How to fix
Upgrade to a fixed version: Google Chrome 63.0.3239.84; xmlsoft libxml2 2.9.5. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1040348
- https://access.redhat.com/errata/RHSA-2017:3401
- https://access.redhat.com/errata/RHSA-2018:0287
- https://bugzilla.gnome.org/show_bug.cgi?id=783160
- https://chromereleases.googleblog.com/2017/12/stable-channel-update-for-desktop.html
- https://crbug.com/727039
- https://lists.debian.org/debian-lts-announce/2017/12/msg00014.html
- https://security.gentoo.org/glsa/201801-03
- https://www.debian.org/security/2018/dsa-4086
- http://www.securitytracker.com/id/1040348
- https://access.redhat.com/errata/RHSA-2017:3401
- https://access.redhat.com/errata/RHSA-2018:0287
Get alerted when CVE-2017-15412 or the next vulnerability affects your stack