What’s Vulnerable › Vulnerabilities
CVE-2017-15422
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-28 · updated 2026-10-14
- Weakness: CWE-190
Description
Integer overflow in international date handling in International Components for Unicode (ICU) for C/C++ before 60.1, as used in V8 in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to perform an out of bounds memory read via a crafted HTML page.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 8.0, 9.0
- Google Chrome: before 63.0.3239.84 — fixed in 63.0.3239.84
- Icu-Project International Components For Unicode: before 60.1 — fixed in 60.1
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: Google Chrome 63.0.3239.84; Icu-Project International Components For Unicode 60.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2017:3401
- https://chromereleases.googleblog.com/2017/12/stable-channel-update-for-desktop.html
- https://crbug.com/774382
- https://security.gentoo.org/glsa/201801-03
- https://usn.ubuntu.com/3610-1/
- https://www.debian.org/security/2018/dsa-4150
- https://access.redhat.com/errata/RHSA-2017:3401
- https://chromereleases.googleblog.com/2017/12/stable-channel-update-for-desktop.html
- https://crbug.com/774382
- https://security.gentoo.org/glsa/201801-03
- https://usn.ubuntu.com/3610-1/
- https://www.debian.org/security/2018/dsa-4150
Get alerted when CVE-2017-15422 or the next vulnerability affects your stack