What’s Vulnerable › Vulnerabilities
CVE-2017-15535
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-01 · updated 2026-06-17
Description
MongoDB 3.4.x before 3.4.10, and 3.5.x-development, has a disabled-by-default configuration setting, networkMessageCompressors (aka wire protocol compression), which exposes a vulnerability when enabled that could be exploited by a malicious attacker to deny service or modify memory.
Affected products
- MongoDB: from 3.4.0 before 3.4.10 — fixed in 3.4.10
How to fix
Upgrade to a fixed version: MongoDB 3.4.10. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101689
- https://jira.mongodb.org/browse/SERVER-31273
- http://www.securityfocus.com/bid/101689
- https://jira.mongodb.org/browse/SERVER-31273
Get alerted when CVE-2017-15535 or the next vulnerability affects your stack