What’s Vulnerable › Vulnerabilities
CVE-2017-15566
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-01 · updated 2026-06-17
- Weakness: CWE-426
Description
Insecure SPANK environment variable handling exists in SchedMD Slurm before 16.05.11, 17.x before 17.02.9, and 17.11.x before 17.11.0rc2, allowing privilege escalation to root during Prolog or Epilog execution.
Affected products
- SchedMD Slurm: before 16.05.11; from 17.02.0 before 17.2.09; 17.11.0-rc1 — fixed in 16.05.11, 17.2.09
How to fix
Upgrade to a fixed version: SchedMD Slurm 16.05.11, 17.2.09. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101675
- https://www.debian.org/security/2017/dsa-4023
- https://www.schedmd.com/news.php?id=193#OPT_193
- http://www.securityfocus.com/bid/101675
- https://www.debian.org/security/2017/dsa-4023
- https://www.schedmd.com/news.php?id=193#OPT_193
Get alerted when CVE-2017-15566 or the next vulnerability affects your stack