What’s Vulnerable › Vulnerabilities
CVE-2017-15640
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-21 · updated 2026-06-17
- Weakness: CWE-79
Description
app/sections/user-menu.php in phpIPAM before 1.3.1 has XSS via the ip parameter.
Affected products
- phpipam/phpipam: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: phpipam/phpipam 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/phpipam/phpipam/issues/1521
- https://github.com/phpipam/phpipam/releases/tag/1.3.1
- https://github.com/phpipam/phpipam/issues/1521
- https://github.com/phpipam/phpipam/releases/tag/1.3.1
Get alerted when CVE-2017-15640 or the next vulnerability affects your stack