What’s Vulnerable › Vulnerabilities
CVE-2017-15655
- Severity: critical (CVSS 9.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-31 · updated 2026-06-17
- Weakness: CWE-119
Description
Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt version <=3.0.0.4.376.X. All have been fixed in version 3.0.0.4.378, but this vulnerability was not previously disclosed. Some end-of-life routers have this version as the newest and thus are vulnerable at this time. This vulnerability allows for RCE with administrator rights when the administrator visits several pages.
Affected products
- Asuswrt: before 3.0.0.4.378 — fixed in 3.0.0.4.378
How to fix
Upgrade to a fixed version: Asuswrt 3.0.0.4.378. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/145921/ASUSWRT-3.0.0.4.382.18495-Session-Hijacking-Information-Disclosure.html
- http://seclists.org/fulldisclosure/2018/Jan/63
- http://sploit.tech/2018/01/16/ASUS-part-I.html
- http://packetstormsecurity.com/files/145921/ASUSWRT-3.0.0.4.382.18495-Session-Hijacking-Information-Disclosure.html
- http://seclists.org/fulldisclosure/2018/Jan/63
- http://sploit.tech/2018/01/16/ASUS-part-I.html
Get alerted when CVE-2017-15655 or the next vulnerability affects your stack