What’s Vulnerable › Vulnerabilities

CVE-2017-15691

Description

In Apache uimaj prior to 2.10.2, Apache uimaj 3.0.0-xxx prior to 3.0.0-beta, Apache uima-as prior to 2.10.2, Apache uimaFIT prior to 2.4.0, Apache uimaDUCC prior to 2.2.2, this vulnerability relates to an XML external entity expansion (XXE) capability of various XML parsers. UIMA as part of its configuration and operation may read XML from various sources, which could be tainted in ways to cause inadvertent disclosure of local files or other internal content.

Affected products

How to fix

Upgrade to a fixed version: Apache Uima-As 2.10.2; Apache UIMA DUCC 2.2.2; Apache Uimafit 2.4.0; Apache Uimaj 2.10.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-15691 or the next vulnerability affects your stack