What’s Vulnerable › Vulnerabilities
CVE-2017-15692
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-27 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Geode before v1.4.0, the TcpServer within the Geode locator opens a network port that deserializes data. If an unprivileged user gains access to the Geode locator, they may be able to cause remote code execution if certain classes are present on the classpath.
Affected products
- Apache Software Foundation Apache Geode: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Geode 1.4.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103205
- https://lists.apache.org/thread.html/d0e00f2e147a9e9b13a6829133092f349b2882bf6860397368a52600%40%3Cannounce.tomcat.apache.org%3E
- http://www.securityfocus.com/bid/103205
- https://lists.apache.org/thread.html/d0e00f2e147a9e9b13a6829133092f349b2882bf6860397368a52600%40%3Cannounce.tomcat.apache.org%3E
Get alerted when CVE-2017-15692 or the next vulnerability affects your stack