What’s Vulnerable › Vulnerabilities
CVE-2017-15693
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-27 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Geode before v1.4.0, the Geode server stores application objects in serialized form. Certain cluster operations and API invocations cause these objects to be deserialized. A user with DATA:WRITE access to the cluster may be able to cause remote code execution if certain classes are present on the classpath.
Affected products
- Apache Software Foundation Apache Geode: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Geode 1.4.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103206
- https://lists.apache.org/thread.html/cc3ec1d06062f54fdaa0357874c1d148fc54bb955f2d2df4ca328a3d%40%3Cuser.geode.apache.org%3E
- http://www.securityfocus.com/bid/103206
- https://lists.apache.org/thread.html/cc3ec1d06062f54fdaa0357874c1d148fc54bb955f2d2df4ca328a3d%40%3Cuser.geode.apache.org%3E
Get alerted when CVE-2017-15693 or the next vulnerability affects your stack