What’s Vulnerable › Vulnerabilities
CVE-2017-15708
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-11 · updated 2026-06-17
- Weakness: CWE-74
Description
In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.
Affected products
- Apache Synapse: 1.0, 1.1, 1.1.1, 1.1.2, 1.2, 2.0.0 (+2)
- Oracle Corporation Financial Services Market Risk Measurement and Management: 8.0.6, 8.0.8
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.56, 8.57
References
- http://www.securityfocus.com/bid/102154
- https://lists.apache.org/thread.html/77f2accf240d25d91b47033e2f8ebec84ffbc6e6627112b2f98b66c9%40%3Cdev.synapse.apache.org%3E
- https://lists.apache.org/thread.html/r0fb289cd38c915b9a13a3376134f96222dd9100f1ef66b41631865c6%40%3Ccommits.doris.apache.org%3E
- https://security.gentoo.org/glsa/202107-37
- https://www.oracle.com/security-alerts/cpujan2020.html
- https://www.oracle.com/security-alerts/cpujul2020.html
- http://www.securityfocus.com/bid/102154
- https://lists.apache.org/thread.html/77f2accf240d25d91b47033e2f8ebec84ffbc6e6627112b2f98b66c9%40%3Cdev.synapse.apache.org%3E
- https://lists.apache.org/thread.html/r0fb289cd38c915b9a13a3376134f96222dd9100f1ef66b41631865c6%40%3Ccommits.doris.apache.org%3E
- https://security.gentoo.org/glsa/202107-37
- https://www.oracle.com/security-alerts/cpujan2020.html
- https://www.oracle.com/security-alerts/cpujul2020.html
Get alerted when CVE-2017-15708 or the next vulnerability affects your stack