What’s Vulnerable › Vulnerabilities
CVE-2017-15865
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-08 · updated 2026-06-17
- Weakness: CWE-200
Description
bgpd in FRRouting (FRR) before 2.0.2 and 3.x before 3.0.2, as used in Cumulus Linux before 3.4.3 and other products, allows remote attackers to obtain sensitive information via a malformed BGP UPDATE packet from a connected peer, which triggers transmission of up to a few thousand unintended bytes because of a mishandled attribute length, aka RN-690 (CM-18492).
Affected products
- FRRouting: before 2.0.2; 3.0, 3.0-rc0, 3.0-rc1, 3.0-rc2, 3.0-rc3, 3.0.1 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: FRRouting 2.0.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101794
- https://frrouting.org/community/security.html
- https://lists.cumulusnetworks.com/pipermail/cumulus-security-announce/2017-November/000009.html
- https://support.cumulusnetworks.com/hc/en-us/articles/115014754307#rn690
- https://support.cumulusnetworks.com/hc/en-us/articles/115014778107-CVE-2017-15865-Malformed-BGP-UPDATE-Triggers-Information-Disclosure
- http://www.securityfocus.com/bid/101794
- https://frrouting.org/community/security.html
- https://lists.cumulusnetworks.com/pipermail/cumulus-security-announce/2017-November/000009.html
- https://support.cumulusnetworks.com/hc/en-us/articles/115014754307#rn690
- https://support.cumulusnetworks.com/hc/en-us/articles/115014778107-CVE-2017-15865-Malformed-BGP-UPDATE-Triggers-Information-Disclosure
Get alerted when CVE-2017-15865 or the next vulnerability affects your stack