What’s Vulnerable › Vulnerabilities
CVE-2017-15896
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-11 · updated 2026-06-17
Description
Node.js was affected by OpenSSL vulnerability CVE-2017-3737 in regards to the use of SSL_read() due to TLS handshake failure. The result was that an active network attacker could send application data to Node.js using the TLS or HTTP2 modules in a way that bypassed TLS authentication and encryption.
Affected products
- Node.js: from 4.0.0 through 4.1.2; from 4.2.0 before 4.8.7; from 6.0.0 through 6.8.1; from 6.9.0 before 6.12.2; from 8.0.0 through 8.8.1; from 8.9.0 before 8.9.3 — fixed in 4.8.7, 6.12.2, 8.9.3, 9.2.1
How to fix
Upgrade to a fixed version: Node.js 4.8.7, 6.12.2, 8.9.3, 9.2.1. Check the vendor advisory for mitigations.
References
- https://nodejs.org/en/blog/vulnerability/december-2017-security-releases/
- https://nodejs.org/en/blog/vulnerability/december-2017-security-releases/
Get alerted when CVE-2017-15896 or the next vulnerability affects your stack