What’s Vulnerable › Vulnerabilities
CVE-2017-15897
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-11 · updated 2026-06-17
- Weakness: CWE-665
Description
Node.js had a bug in versions 8.X and 9.X which caused buffers to not be initialized when the encoding for the fill value did not match the encoding specified. For example, 'Buffer.alloc(0x100, "This is not correctly encoded", "hex");' The buffer implementation was updated such that the buffer will be initialized to all zeros in these cases.
Affected products
- Node.js: from 8.0.0 through 8.8.1; from 8.9.0 before 8.9.3; from 9.0.0 before 9.2.1 — fixed in 8.9.3, 9.2.1
How to fix
Upgrade to a fixed version: Node.js 8.9.3, 9.2.1. Check the vendor advisory for mitigations.
References
- https://nodejs.org/en/blog/vulnerability/december-2017-security-releases/
- https://nodejs.org/en/blog/vulnerability/december-2017-security-releases/
Get alerted when CVE-2017-15897 or the next vulnerability affects your stack