What’s Vulnerable › Vulnerabilities

CVE-2017-15951

Description

The KEYS subsystem in the Linux kernel before 4.13.10 does not correctly synchronize the actions of updating versus finding a key in the "negative" state to avoid a race condition, which allows local users to cause a denial of service or possibly have unspecified other impact via crafted system calls.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.13.10, 4.4.95, 4.9.59. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-15951 or the next vulnerability affects your stack