What’s Vulnerable › Vulnerabilities
CVE-2017-16007
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-04 · updated 2026-06-17
- Weakness: CWE-200
Description
node-jose is a JavaScript implementation of the JSON Object Signing and Encryption (JOSE) for current web browsers and node.js-based servers. node-jose earlier than version 0.9.3 is vulnerable to an invalid curve attack. This allows an attacker to recover the private secret key when JWE with Key Agreement with Elliptic Curve Diffie-Hellman Ephemeral Static (ECDH-ES) is used.
Affected products
- HackerOne node-jose node module: before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: HackerOne node-jose node module 0.9.3. Check the vendor advisory for mitigations.
References
- http://blog.intothesymmetry.com/2017/03/critical-vulnerability-in-json-web.html
- https://gist.github.com/asanso/fa25685348051ef6a28d49aa0f27a4ae
- https://github.com/cisco/node-jose
- https://nodesecurity.io/advisories/324
- http://blog.intothesymmetry.com/2017/03/critical-vulnerability-in-json-web.html
- https://gist.github.com/asanso/fa25685348051ef6a28d49aa0f27a4ae
- https://github.com/cisco/node-jose
- https://nodesecurity.io/advisories/324
Get alerted when CVE-2017-16007 or the next vulnerability affects your stack