What’s Vulnerable › Vulnerabilities
CVE-2017-16014
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-04 · updated 2026-06-17
- Weakness: CWE-703
Description
Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.
Affected products
- HackerOne http-proxy node module: before 0.7.0 — fixed in 0.7.0
How to fix
Upgrade to a fixed version: HackerOne http-proxy node module 0.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/nodejitsu/node-http-proxy/pull/101
- https://nodesecurity.io/advisories/323
- https://github.com/nodejitsu/node-http-proxy/pull/101
- https://nodesecurity.io/advisories/323
Get alerted when CVE-2017-16014 or the next vulnerability affects your stack