What’s Vulnerable › Vulnerabilities
CVE-2017-16041
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-04 · updated 2026-06-17
- Weakness: CWE-311
Description
ikst versions before 1.1.2 download resources over HTTP, which leaves it vulnerable to MITM attacks.
Affected products
- HackerOne ikst node module: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: HackerOne ikst node module 1.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-16041 or the next vulnerability affects your stack