What’s Vulnerable › Vulnerabilities
CVE-2017-16042
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-04 · updated 2026-06-17
- Weakness: CWE-94
Description
Growl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.
Affected products
- HackerOne growl node module: before 1.10.2 — fixed in 1.10.2
How to fix
Upgrade to a fixed version: HackerOne growl node module 1.10.2. Check the vendor advisory for mitigations.
References
- https://github.com/tj/node-growl/issues/60
- https://github.com/tj/node-growl/pull/61
- https://nodesecurity.io/advisories/146
- https://github.com/tj/node-growl/issues/60
- https://github.com/tj/node-growl/pull/61
- https://nodesecurity.io/advisories/146
Get alerted when CVE-2017-16042 or the next vulnerability affects your stack