What’s Vulnerable › Vulnerabilities
CVE-2017-16082
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-94
Description
A remote code execution vulnerability was found within the pg module when the remote database or query specifies a specially crafted column name. There are 2 likely scenarios in which one would likely be vulnerable. 1) Executing unsafe, user-supplied sql which contains a malicious column name. 2) Connecting to an untrusted database and executing a query which returns results where any of the column names are malicious.
Affected products
- HackerOne pg node module: from 2.0.0 before 2.11.2; from 3.0.0 before 3.6.4; from 4.0.0 before 4.5.7; from 5.0.0 (excl.) before 5.2.1; from 6.0.0 before 6.4.2; from 7.0.0 before 7.1.2 — fixed in 2.11.2, 3.6.4, 4.5.7, 5.2.1, 6.4.2, 7.1.2
How to fix
Upgrade to a fixed version: HackerOne pg node module 2.11.2, 3.6.4, 4.5.7, 5.2.1. Check the vendor advisory for mitigations.
References
- https://node-postgres.com/announcements#2017-08-12-code-execution-vulnerability
- https://nodesecurity.io/advisories/521
- https://node-postgres.com/announcements#2017-08-12-code-execution-vulnerability
- https://nodesecurity.io/advisories/521
Get alerted when CVE-2017-16082 or the next vulnerability affects your stack