What’s Vulnerable › Vulnerabilities
CVE-2017-16085
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-22
Description
tinyserver2 is a webserver for static files. tinyserver2 is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the URL.
Affected products
- HackerOne tinyserver2 node module: before 0.6.0 — fixed in 0.6.0
How to fix
Upgrade to a fixed version: HackerOne tinyserver2 node module 0.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/JacksonGL/NPM-Vuln-PoC/tree/master/directory-traversal/tinyserver2
- https://nodesecurity.io/advisories/371
- https://github.com/JacksonGL/NPM-Vuln-PoC/tree/master/directory-traversal/tinyserver2
- https://nodesecurity.io/advisories/371
Get alerted when CVE-2017-16085 or the next vulnerability affects your stack