What’s Vulnerable › Vulnerabilities
CVE-2017-16099
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-400
Description
The no-case module is vulnerable to regular expression denial of service. When malicious untrusted user input is passed into no-case it can block the event loop causing a denial of service condition.
Affected products
- HackerOne no-case node module: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: HackerOne no-case node module 2.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/blakeembrey/no-case/issues/17
- https://nodesecurity.io/advisories/529
- https://github.com/blakeembrey/no-case/issues/17
- https://nodesecurity.io/advisories/529
Get alerted when CVE-2017-16099 or the next vulnerability affects your stack