What’s Vulnerable › Vulnerabilities
CVE-2017-16114: Regular Expression Denial of Service in marked
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-400
Description
The marked module is vulnerable to a regular expression denial of service. Based on the information published in the public issue, 1k characters can block for around 6 seconds.
Affected products
- markedjs marked: before 0.3.9 — fixed in 0.3.9
- Npm Marked: before 0.3.9 — fixed in 0.3.9
How to fix
Upgrade to a fixed version: markedjs marked 0.3.9; Npm Marked 0.3.9. Check the vendor advisory for mitigations.
References
- https://github.com/chjj/marked/issues/937
- https://nodesecurity.io/advisories/531
- https://github.com/chjj/marked/issues/937
- https://nodesecurity.io/advisories/531
Get alerted when CVE-2017-16114 or the next vulnerability affects your stack