What’s Vulnerable › Vulnerabilities
CVE-2017-16118
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-400
Description
The forwarded module is used by the Express.js framework to handle the X-Forwarded-For header. It is vulnerable to a regular expression denial of service when it's passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Affected products
- HackerOne forwarded node module: before 0.1.2 — fixed in 0.1.2
How to fix
Upgrade to a fixed version: HackerOne forwarded node module 0.1.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104427
- https://nodesecurity.io/advisories/527
- http://www.securityfocus.com/bid/104427
- https://nodesecurity.io/advisories/527
Get alerted when CVE-2017-16118 or the next vulnerability affects your stack