What’s Vulnerable › Vulnerabilities
CVE-2017-16136
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-400
Description
method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.
Affected products
- HackerOne method-override node module: before 2.3.10 — fixed in 2.3.10
How to fix
Upgrade to a fixed version: HackerOne method-override node module 2.3.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-16136 or the next vulnerability affects your stack