What’s Vulnerable › Vulnerabilities

CVE-2017-16138: mime Regular Expression Denial of Service when MIME lookup performed on untrusted user input

Description

The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.

Affected products

How to fix

Upgrade to a fixed version: HackerOne mime node module 1.4.1, 2.0.3; Npm Mime 2.0.3, 1.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-16138 or the next vulnerability affects your stack