What’s Vulnerable › Vulnerabilities
CVE-2017-16248
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-01 · updated 2026-06-17
- Weakness: CWE-200
Description
The Catalyst-Plugin-Static-Simple module before 0.34 for Perl allows remote attackers to read arbitrary files if there is a '.' character anywhere in the pathname, which differs from the intended policy of allowing access only when the filename itself has a '.' character.
Affected products
- Catalyst-Plugin-Static-Simple Project Catalyst-Plugin-Static-Simple: before 0.34 — fixed in 0.34
How to fix
Upgrade to a fixed version: Catalyst-Plugin-Static-Simple Project Catalyst-Plugin-Static-Simple 0.34. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/880458
- https://metacpan.org/changes/distribution/Catalyst-Plugin-Static-Simple
- https://rt.cpan.org/Public/Bug/Display.html?id=120558
- https://bugs.debian.org/880458
- https://metacpan.org/changes/distribution/Catalyst-Plugin-Static-Simple
- https://rt.cpan.org/Public/Bug/Display.html?id=120558
Get alerted when CVE-2017-16248 or the next vulnerability affects your stack