What’s Vulnerable › Vulnerabilities
CVE-2017-16526
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-04 · updated 2026-06-17
- Weakness: CWE-119
Description
drivers/uwb/uwbd.c in the Linux kernel before 4.13.6 allows local users to cause a denial of service (general protection fault and system crash) or possibly have unspecified other impact via a crafted USB device.
Affected products
- Canonical Ubuntu Linux: 14.04
- Debian Linux: 8.0
- Linux kernel: before 3.2.97; from 3.3 before 3.16.52; from 3.17 before 3.18.75; from 3.19 before 4.1.46; from 4.2 before 4.4.92; from 4.5 before 4.9.55 — fixed in 3.16.52, 3.18.75, 3.2.97, 4.1.46, 4.13.6, 4.4.92
How to fix
Upgrade to a fixed version: Linux kernel 3.16.52, 3.18.75, 3.2.97, 4.1.46. Check the vendor advisory for mitigations.
References
- https://github.com/torvalds/linux/commit/bbf26183b7a6236ba602f4d6a2f7cade35bba043
- https://groups.google.com/d/msg/syzkaller/zROBxKXzHDk/5I6aZ3O2AgAJ
- https://lists.debian.org/debian-lts-announce/2018/05/msg00000.html
- https://usn.ubuntu.com/3754-1/
- https://www.debian.org/security/2018/dsa-4187
- https://github.com/torvalds/linux/commit/bbf26183b7a6236ba602f4d6a2f7cade35bba043
- https://groups.google.com/d/msg/syzkaller/zROBxKXzHDk/5I6aZ3O2AgAJ
- https://lists.debian.org/debian-lts-announce/2018/05/msg00000.html
- https://usn.ubuntu.com/3754-1/
- https://www.debian.org/security/2018/dsa-4187
Get alerted when CVE-2017-16526 or the next vulnerability affects your stack