What’s Vulnerable › Vulnerabilities
CVE-2017-16528
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-04 · updated 2026-06-17
- Weakness: CWE-416
Description
sound/core/seq_device.c in the Linux kernel before 4.13.4 allows local users to cause a denial of service (snd_rawmidi_dev_seq_free use-after-free and system crash) or possibly have unspecified other impact via a crafted USB device.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Linux kernel: from 3.19 before 4.1.47; from 4.2 before 4.4.99; from 4.5 before 4.9.63; from 4.10 before 4.13.4 — fixed in 4.1.47, 4.13.4, 4.4.99, 4.9.63
How to fix
Upgrade to a fixed version: Linux kernel 4.1.47, 4.13.4, 4.4.99, 4.9.63. Check the vendor advisory for mitigations.
References
- https://github.com/torvalds/linux/commit/fc27fe7e8deef2f37cba3f2be2d52b6ca5eb9d57
- https://groups.google.com/d/msg/syzkaller/kuZzDHGkQu8/5du20rZEAAAJ
- https://usn.ubuntu.com/3619-1/
- https://usn.ubuntu.com/3619-2/
- https://github.com/torvalds/linux/commit/fc27fe7e8deef2f37cba3f2be2d52b6ca5eb9d57
- https://groups.google.com/d/msg/syzkaller/kuZzDHGkQu8/5du20rZEAAAJ
- https://usn.ubuntu.com/3619-1/
- https://usn.ubuntu.com/3619-2/
Get alerted when CVE-2017-16528 or the next vulnerability affects your stack