What’s Vulnerable › Vulnerabilities

CVE-2017-16530

Description

The uas driver in the Linux kernel before 4.13.6 allows local users to cause a denial of service (out-of-bounds read and system crash) or possibly have unspecified other impact via a crafted USB device, related to drivers/usb/storage/uas-detect.h and drivers/usb/storage/uas.c.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.16.50, 3.18.75, 4.1.46, 4.13.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-16530 or the next vulnerability affects your stack