What’s Vulnerable › Vulnerabilities
CVE-2017-16533
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-04 · updated 2026-06-17
- Weakness: CWE-125
Description
The usbhid_parse function in drivers/hid/usbhid/hid-core.c in the Linux kernel before 4.13.8 allows local users to cause a denial of service (out-of-bounds read and system crash) or possibly have unspecified other impact via a crafted USB device.
Affected products
- Canonical Ubuntu Linux: 14.04
- Debian Linux: 7.0
- Linux kernel: before 3.2.95; from 3.3 before 3.16.50; from 3.17 before 3.18.76; from 3.19 before 4.1.46; from 4.2 before 4.4.93; from 4.5 before 4.9.57 — fixed in 3.16.50, 3.18.76, 3.2.95, 4.1.46, 4.13.8, 4.4.93
How to fix
Upgrade to a fixed version: Linux kernel 3.16.50, 3.18.76, 3.2.95, 4.1.46. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102026
- https://github.com/torvalds/linux/commit/f043bfc98c193c284e2cd768fefabe18ac2fed9b
- https://groups.google.com/d/msg/syzkaller/CxkJ9QZgwlM/O3IOvAaGAwAJ
- https://lists.debian.org/debian-lts-announce/2017/12/msg00004.html
- https://usn.ubuntu.com/3754-1/
- http://www.securityfocus.com/bid/102026
- https://github.com/torvalds/linux/commit/f043bfc98c193c284e2cd768fefabe18ac2fed9b
- https://groups.google.com/d/msg/syzkaller/CxkJ9QZgwlM/O3IOvAaGAwAJ
- https://lists.debian.org/debian-lts-announce/2017/12/msg00004.html
- https://usn.ubuntu.com/3754-1/
Get alerted when CVE-2017-16533 or the next vulnerability affects your stack