What’s Vulnerable › Vulnerabilities
CVE-2017-16540
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-04 · updated 2026-06-17
- Weakness: CWE-200
Description
OpenEMR before 5.0.0 Patch 5 allows unauthenticated remote database copying because setup.php exposes functionality for cloning an existing OpenEMR site to an arbitrary attacker-controlled MySQL server via vectors involving a crafted state parameter.
Affected products
- openemr: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: openemr 5.0.0. Check the vendor advisory for mitigations.
References
- http://www.open-emr.org/wiki/index.php/OpenEMR_Patches
- http://www.securityfocus.com/bid/101983
- https://isears.github.io/jekyll/update/2017/10/28/openemr-database-disclosure.html
- http://www.open-emr.org/wiki/index.php/OpenEMR_Patches
- http://www.securityfocus.com/bid/101983
- https://isears.github.io/jekyll/update/2017/10/28/openemr-database-disclosure.html
Get alerted when CVE-2017-16540 or the next vulnerability affects your stack