What’s Vulnerable › Vulnerabilities
CVE-2017-16610
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-23 · updated 2026-06-17
- Weakness: CWE-22
Description
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Netgain Enterprise Manager. Authentication is not required to exploit this vulnerability. The specific flaw exists within upload_save_do.jsp. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to execute code under the context of the current user. Was ZDI-CAN-4751.
Affected products
- NetGain Systems Enterprise Manager: before 7.2.766 — fixed in 7.2.766
How to fix
Upgrade to a fixed version: NetGain Systems Enterprise Manager 7.2.766. Check the vendor advisory for mitigations.
References
- https://www.tenable.com/security/research/tra-2018-02
- https://zerodayinitiative.com/advisories/ZDI-17-952
- https://www.tenable.com/security/research/tra-2018-02
- https://zerodayinitiative.com/advisories/ZDI-17-952
Get alerted when CVE-2017-16610 or the next vulnerability affects your stack