What’s Vulnerable › Vulnerabilities
CVE-2017-16616
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-08 · updated 2026-06-17
Description
An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
Affected products
- Pyanyapi Project Pyanyapi: before 0.6.1 — fixed in 0.6.1
How to fix
Upgrade to a fixed version: Pyanyapi Project Pyanyapi 0.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/Stranger6667/pyanyapi/issues/41
- https://github.com/Stranger6667/pyanyapi/releases/tag/0.6.1
- https://joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16616-yamlparser-in-pyanyapi/
- https://pypi.python.org/pypi/pyanyapi/0.6.1
- https://github.com/Stranger6667/pyanyapi/issues/41
- https://github.com/Stranger6667/pyanyapi/releases/tag/0.6.1
- https://joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16616-yamlparser-in-pyanyapi/
- https://pypi.python.org/pypi/pyanyapi/0.6.1
Get alerted when CVE-2017-16616 or the next vulnerability affects your stack