What’s Vulnerable › Vulnerabilities
CVE-2017-16618
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-08 · updated 2026-06-17
Description
An exploitable vulnerability exists in the YAML loading functionality of util.py in OwlMixin before 2.0.0a12. A "Load YAML" string or file (aka load_yaml or load_yamlf) can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
Affected products
- Owlmixin Project Owlmixin: before 2.0.0; 2.0.0-alpha1, 2.0.0-alpha10, 2.0.0-alpha11, 2.0.0-alpha2, 2.0.0-alpha3, 2.0.0-alpha4 (+5) — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Owlmixin Project Owlmixin 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/tadashi-aikawa/owlmixin/commit/5d0575303f6df869a515ced4285f24ba721e0d4e
- https://github.com/tadashi-aikawa/owlmixin/issues/12
- https://joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16618-convert-through-owlmixin/
- https://github.com/tadashi-aikawa/owlmixin/commit/5d0575303f6df869a515ced4285f24ba721e0d4e
- https://github.com/tadashi-aikawa/owlmixin/issues/12
- https://joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16618-convert-through-owlmixin/
Get alerted when CVE-2017-16618 or the next vulnerability affects your stack