What’s Vulnerable › Vulnerabilities

CVE-2017-16642

Description

In PHP before 5.6.32, 7.x before 7.0.25, and 7.1.x before 7.1.11, an error in the date extension's timelib_meridian handling of 'front of' and 'back of' directives could be used by attackers able to supply date strings to leak information from the interpreter, related to ext/date/lib/parse_date.c out-of-bounds reads affecting the php_parse_date function. NOTE: this is a different issue than CVE-2017-11145.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.6.32, 7.0.25, 7.1.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-16642 or the next vulnerability affects your stack