What’s Vulnerable › Vulnerabilities
CVE-2017-16664
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-21 · updated 2026-06-17
- Weakness: CWE-94
Description
Code injection exists in Kernel/System/Spelling.pm in Open Ticket Request System (OTRS) 5 before 5.0.24, 4 before 4.0.26, and 3.3 before 3.3.20. In the agent interface, an authenticated remote attacker can execute shell commands as the webserver user via URL manipulation.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- OTRS AG OTRS: from 3.3.0 before 3.3.20; from 4.0.0 before 4.0.26; from 5.0.0 before 5.0.24 — fixed in 3.3.20, 4.0.26, 5.0.24
How to fix
Upgrade to a fixed version: OTRS AG OTRS 3.3.20, 4.0.26, 5.0.24. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2017/12/msg00015.html
- https://www.debian.org/security/2017/dsa-4047
- https://www.otrs.com/security-advisory-2017-07-security-update-otrs-framework/
- https://lists.debian.org/debian-lts-announce/2017/12/msg00015.html
- https://www.debian.org/security/2017/dsa-4047
- https://www.otrs.com/security-advisory-2017-07-security-update-otrs-framework/
Get alerted when CVE-2017-16664 or the next vulnerability affects your stack