What’s Vulnerable › Vulnerabilities
CVE-2017-16666
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 80.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-05 · updated 2026-06-17
- Weakness: CWE-78
Description
Xplico before 1.2.1 allows remote authenticated users to execute arbitrary commands via shell metacharacters in the name of an uploaded PCAP file. NOTE: this issue can be exploited without authentication by leveraging the user registration feature.
Affected products
- Xplico: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: Xplico 1.2.1. Check the vendor advisory for mitigations.
References
- http://blog.securityonion.net/2017/11/security-advisory-for-xplico-120.html
- http://packetstormsecurity.com/files/145639/Xplico-Remote-Code-Execution.html
- http://www.rapid7.com/db/modules/exploit/linux/http/xplico_exec
- https://pentest.blog/advisory-xplico-unauthenticated-remote-code-execution-cve-2017-16666/
- https://www.exploit-db.com/exploits/43430/
- https://www.xplico.org/archives/1538
- http://blog.securityonion.net/2017/11/security-advisory-for-xplico-120.html
- http://packetstormsecurity.com/files/145639/Xplico-Remote-Code-Execution.html
- http://www.rapid7.com/db/modules/exploit/linux/http/xplico_exec
- https://pentest.blog/advisory-xplico-unauthenticated-remote-code-execution-cve-2017-16666/
- https://www.exploit-db.com/exploits/43430/
- https://www.xplico.org/archives/1538
Get alerted when CVE-2017-16666 or the next vulnerability affects your stack