What’s Vulnerable › Vulnerabilities
CVE-2017-16758
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in admin/partials/uif-access-token-display.php in the Ultimate Instagram Feed plugin before 1.3 for WordPress allows remote attackers to inject arbitrary web script or HTML via the "access_token" parameter.
Affected products
- Ultimate Instagram Feed Project Ultimate Instagram Feed: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: Ultimate Instagram Feed Project Ultimate Instagram Feed 1.3. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/144921/WordPress-Ultimate-Instagram-Feed-1.2-Cross-Site-Scripting.html
- https://plugins.trac.wordpress.org/changeset/1758562/ultimate-instagram-feed
- https://wpvulndb.com/vulnerabilities/8947
- https://packetstormsecurity.com/files/144921/WordPress-Ultimate-Instagram-Feed-1.2-Cross-Site-Scripting.html
- https://plugins.trac.wordpress.org/changeset/1758562/ultimate-instagram-feed
- https://wpvulndb.com/vulnerabilities/8947
Get alerted when CVE-2017-16758 or the next vulnerability affects your stack