What’s Vulnerable › Vulnerabilities
CVE-2017-16772
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-22 · updated 2026-06-17
- Weakness: CWE-434
Description
Improper input validation vulnerability in SYNOPHOTO_Flickr_MultiUpload in Synology Photo Station before 6.8.3-3463 and before 6.3-2971 allows remote authenticated users to execute arbitrary codes via the prog_id parameter.
Affected products
- Synology Photo Station: from 6.8 before 6.8.3-3463; from 6.3 before 6.3-2971 — fixed in 6.3-2971, 6.8.3-3463
How to fix
Upgrade to a fixed version: Synology Photo Station 6.3-2971, 6.8.3-3463. Check the vendor advisory for mitigations.
References
- https://www.synology.com/en-global/support/security/Synology_SA_18_02
- https://www.synology.com/en-global/support/security/Synology_SA_18_02
Get alerted when CVE-2017-16772 or the next vulnerability affects your stack