What’s Vulnerable › Vulnerabilities
CVE-2017-16801
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in Octopus Deploy 3.7.0-3.17.13 (fixed in 3.17.14) allows remote authenticated users to inject arbitrary web script or HTML via the Step Template Name parameter.
Affected products
- Octopus Deploy: from 3.7.0 through 3.17.3
References
- https://github.com/OctopusDeploy/Issues/issues/3915
- https://github.com/OctopusDeploy/Issues/issues/3915
Get alerted when CVE-2017-16801 or the next vulnerability affects your stack