What’s Vulnerable › Vulnerabilities
CVE-2017-16810
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the All Variables tab in Octopus Deploy 3.4.0-3.13.6 (fixed in 3.13.7) allows remote attackers to inject arbitrary web script or HTML via the Variable Set Name parameter.
Affected products
- Octopus Deploy: from 3.4.0 through 3.13.6
References
- https://github.com/OctopusDeploy/Issues/issues/3919
- https://github.com/OctopusDeploy/Issues/issues/3919
Get alerted when CVE-2017-16810 or the next vulnerability affects your stack