What’s Vulnerable › Vulnerabilities
CVE-2017-16842
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in admin/google_search_console/class-gsc-table.php in the Yoast SEO plugin before 5.8.0 for WordPress allows remote attackers to inject arbitrary web script or HTML.
Affected products
- Yoast Wordpress Seo: before 5.8.0 — fixed in 5.8.0
How to fix
Upgrade to a fixed version: Yoast Wordpress Seo 5.8.0. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/145080/WordPress-Yoast-SEO-Cross-Site-Scripting.html
- https://plugins.trac.wordpress.org/changeset/1766831/wordpress-seo/trunk/admin/google_search_console/class-gsc-table.php
- https://wordpress.org/plugins/wordpress-seo/#developers
- https://packetstormsecurity.com/files/145080/WordPress-Yoast-SEO-Cross-Site-Scripting.html
- https://plugins.trac.wordpress.org/changeset/1766831/wordpress-seo/trunk/admin/google_search_console/class-gsc-table.php
- https://wordpress.org/plugins/wordpress-seo/#developers
Get alerted when CVE-2017-16842 or the next vulnerability affects your stack