What’s Vulnerable › Vulnerabilities
CVE-2017-16852
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-16 · updated 2026-06-17
- Weakness: CWE-347
Description
shibsp/metadata/DynamicMetadataProvider.cpp in the Dynamic MetadataProvider plugin in Shibboleth Service Provider before 2.6.1 fails to properly configure itself with the MetadataFilter plugins and does not perform critical security checks such as signature verification, enforcement of validity periods, and other checks specific to deployments, aka SSPCPP-763.
Affected products
- Debian Linux: 8.0, 9.0
- Shibboleth Service Provider: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: Shibboleth Service Provider 2.6.1. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/881857
- https://git.shibboleth.net/view/?p=cpp-sp.git%3Ba=commit%3Bh=b66cceb0e992c351ad5e2c665229ede82f261b16
- https://lists.debian.org/debian-lts-announce/2017/11/msg00025.html
- https://shibboleth.net/community/advisories/secadv_20171115.txt
- https://www.debian.org/security/2017/dsa-4038
- https://bugs.debian.org/881857
- https://git.shibboleth.net/view/?p=cpp-sp.git%3Ba=commit%3Bh=b66cceb0e992c351ad5e2c665229ede82f261b16
- https://lists.debian.org/debian-lts-announce/2017/11/msg00025.html
- https://shibboleth.net/community/advisories/secadv_20171115.txt
- https://www.debian.org/security/2017/dsa-4038
Get alerted when CVE-2017-16852 or the next vulnerability affects your stack