What’s Vulnerable › Vulnerabilities
CVE-2017-16858
- Severity: medium (CVSS 6.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-31 · updated 2026-06-17
- Weakness: CWE-863
Description
The 'crowd-application' plugin module (notably used by the Google Apps plugin) in Atlassian Crowd from version 1.5.0 before version 3.1.2 allowed an attacker to impersonate a Crowd user in REST requests by being able to authenticate to a directory bound to an application using the feature. Given the following situation: the Crowd application is bound to directory 1 and has a user called admin and the Google Apps application is bound to directory 2, which also has a user called admin, it was possible to authenticate REST requests using the credentials of the user coming from directory 2 and impersonate the user from directory 1.
Affected products
- Atlassian Crowd: from 1.5.0 before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: Atlassian Crowd 3.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-16858 or the next vulnerability affects your stack