What’s Vulnerable › Vulnerabilities
CVE-2017-16861
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-01 · updated 2026-06-17
Description
It was possible for double OGNL evaluation in certain redirect action and in WebWork URL and Anchor tags in JSP files to occur. An attacker who can access the web interface of Fisheye or Crucible or who hosts a website that a user who can access the web interface of Fisheye or Crucible visits, is able to exploit this vulnerability to execute Java code of their choice on systems that run a vulnerable version of Fisheye or Crucible. All versions of Fisheye and Crucible before 4.4.5 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.2 (the fixed version for 4.5.x) are affected by this vulnerability.
Affected products
- Atlassian Crucible: before 4.4.5; from 4.5.0 before 4.5.2 — fixed in 4.4.5, 4.5.2
- Atlassian Fisheye: before 4.4.5; from 4.5.0 before 4.5.2 — fixed in 4.4.5, 4.5.2
How to fix
Upgrade to a fixed version: Atlassian Crucible 4.4.5, 4.5.2; Atlassian Fisheye 4.4.5, 4.5.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102971
- https://confluence.atlassian.com/x/h-QyO
- https://confluence.atlassian.com/x/iPQyO
- https://jira.atlassian.com/browse/CRUC-8156
- https://jira.atlassian.com/browse/FE-6991
- http://www.securityfocus.com/bid/102971
- https://confluence.atlassian.com/x/h-QyO
- https://confluence.atlassian.com/x/iPQyO
- https://jira.atlassian.com/browse/CRUC-8156
- https://jira.atlassian.com/browse/FE-6991
Get alerted when CVE-2017-16861 or the next vulnerability affects your stack