What’s Vulnerable › Vulnerabilities
CVE-2017-16872
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-17 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in Teluu pjproject (pjlib and pjlib-util) in PJSIP before 2.7.1. Parsing the numeric header fields in a SIP message (like cseq, ttl, port, etc.) all had the potential to overflow, either causing unintended values to be captured or, if the values were subsequently converted back to strings, a buffer overrun. This will lead to a potential exploit using carefully crafted invalid values.
Affected products
- Debian Linux: 9.0
- teluu pjsip: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: teluu pjsip 2.7.1. Check the vendor advisory for mitigations.
References
- https://trac.pjsip.org/repos/milestone/release-2.7.1
- https://trac.pjsip.org/repos/ticket/2056
- https://www.debian.org/security/2018/dsa-4170
- https://trac.pjsip.org/repos/milestone/release-2.7.1
- https://trac.pjsip.org/repos/ticket/2056
- https://www.debian.org/security/2018/dsa-4170
Get alerted when CVE-2017-16872 or the next vulnerability affects your stack