What’s Vulnerable › Vulnerabilities
CVE-2017-16875
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-17 · updated 2026-06-17
Description
An issue was discovered in Teluu pjproject (pjlib and pjlib-util) in PJSIP before 2.7.1. The ioqueue component may issue a double key unregistration after an attacker initiates a socket connection with specific settings and sequences. Such double key unregistration will trigger an integer overflow, which may cause ioqueue backends to reject future key registrations.
Affected products
- teluu pjsip: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: teluu pjsip 2.7.1. Check the vendor advisory for mitigations.
References
- https://trac.pjsip.org/repos/milestone/release-2.7.1
- https://trac.pjsip.org/repos/ticket/2055
- https://www.debian.org/security/2018/dsa-4170
- https://trac.pjsip.org/repos/milestone/release-2.7.1
- https://trac.pjsip.org/repos/ticket/2055
- https://www.debian.org/security/2018/dsa-4170
Get alerted when CVE-2017-16875 or the next vulnerability affects your stack