What’s Vulnerable › Vulnerabilities
CVE-2017-16877
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-17 · updated 2026-06-17
- Weakness: CWE-22
Description
ZEIT Next.js before 2.4.1 has directory traversal under the /_next and /static request namespace, allowing attackers to obtain sensitive information.
Affected products
- zeit next.js: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: zeit next.js 2.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/02fe7cf63f6265d73bdaf8bc50a4f2fb539dcd00
- https://github.com/zeit/next.js/releases/tag/2.4.1
- https://github.com/vercel/next.js/commit/02fe7cf63f6265d73bdaf8bc50a4f2fb539dcd00
- https://github.com/zeit/next.js/releases/tag/2.4.1
Get alerted when CVE-2017-16877 or the next vulnerability affects your stack