What’s Vulnerable › Vulnerabilities
CVE-2017-16884
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in MistServer before 2.13 allows remote attackers to inject arbitrary web script or HTML via vectors related to failed authentication requests alerts.
Affected products
- Mistserver: before 2.13 — fixed in 2.13
How to fix
Upgrade to a fixed version: Mistserver 2.13. Check the vendor advisory for mitigations.
References
- http://hyp3rlinx.altervista.org/advisories/MIST-SERVER-v2.12-UNAUTHENTICATED-PERSISTENT-XSS-CVE-2017-16884.txt
- http://packetstormsecurity.com/files/145182/MistServer-2.12-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2017/Dec/2
- https://news.mistserver.org/news/78/Stable+release+2.13+now+available%21
- https://www.exploit-db.com/exploits/43205/
- http://hyp3rlinx.altervista.org/advisories/MIST-SERVER-v2.12-UNAUTHENTICATED-PERSISTENT-XSS-CVE-2017-16884.txt
- http://packetstormsecurity.com/files/145182/MistServer-2.12-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2017/Dec/2
- https://news.mistserver.org/news/78/Stable+release+2.13+now+available%21
- https://www.exploit-db.com/exploits/43205/
Get alerted when CVE-2017-16884 or the next vulnerability affects your stack